Debian

[Twitter]Twitter Command-Line: Twitter desde la consola de linux

Aun con festejo y todo pero no podemos dejar de postear cosas interesantes y me agrado mucho(espero no sea el cache), que mis suscritos mediante feed RSS sigan siendo 184, vamos suscribanse, ya casi llegamos a 200 y luego 400 y luego 1000, asi pronto dominaremos al mundo, bueno no tanto.

En genbeta me encontré con Twitter Command Line Client, el cual como su nombre lo indica es para hacer Twitteos de una forma mas chida, osea usando linea de comandos, claro esto solo es apto para los mas geeks, ya que es un programa escrito en perl el cual mediante una serie de comandos te permite twittear, desde una consola y que tu jefe piense que estas haciendo los respaldos del server ;-)

Para usarlo solo sigue estos sencillos pasos.

./twitter.pl mensaje_a_publicar

  • Mostrar las últimas 20 actualizaciones de tus contactos:

./twitter.pl -r

  • Enviar el texto especificado como mensaje al usuario nombre:

./twitter.pl nombre mensaje

  • Añadir el contacto nombre a tu lista de amigos:

./twitter.pl -F nombre

La primera vez que es lanzado pide el nombre de usuario y la contraseña, que almacena en el fichero de configuración del programa y no requiere volver a introducirlos. También se pueden crear ficheros de configuración alternativos, para poder actualizar desde diferentes cuentas, y se podrán cargar en la aplicación ejecutándola con la opción -f.

twitter-cmd-2

Como verán es algo raro este programa pero vamos se ve bastante geek y es uno mas en la larga lista de aplicaciones para twitter

Imagenes, texto citado y fuente |Twitter Command-Line: twitteando desde la línea de comandos en GNU/Linux

[Debian] Debian,su grave fallo de seguridad y la entrevista a un desarrollador de Debian

Bueno antes de postearles el tutoría que no le he terminado(todo por culpa de compiz-fusion el cual se pone loco al querer instalarlo pero bueno mi sistema esta estable, digamos que lo estoy poniendo chido), quiero comentarles esto.

Hace varios días,se había comentado de un grave fallo en la distribución GNU/Linux Debian, y sus derivados(Ubuntu, Kubuntu, Edubuntu,*buntu, Knoppix, Gnoppix entre otros), el cual había estado oculto durante dos años hasta que fue descubierto dicho fallo.

Debian

Al parecer “Hace dos años, al querer solucionar un problema y debido a un malentendido, uno de ellos borró una línea de código del paquete de herramientas OpenSSL del sistema.”

Lo que puede ocurrir por este fallo es lo siguiente:

“La línea borrada afectaba a la aleatoriedad de las claves, necesaria para que sean fuertes. Esta quedó tan reducida que hacía muy fácil romperlas y atacar cualquier operación realizada con ellas. Por ejemplo, se podría impersonar el certificado de un banco o una tienda en línea, crear una web falsa y hacer creer a los visitantes que están en la legítima.

O descifrar las comunicaciones entre una web segura y sus clientes y cazar todos los datos que se cruzasen entre ellos. O tener en pocos minutos el control total del servidor de una empresa. O acceder a la Red Privada Virtual de la misma y espiar sus movimientos. O cambiar la configuración de un servidor de nombres de dominio y llevar a la gente donde el atacante quiera.”

El fallo no es exclusivo de Debian. Afecta también a las distribuciones derivadas de esta, como Ubuntu, la más popular entre usuarios domésticos, y Linex, creada por el gobierno de Extremadura. Tampoco están a salvo otros sistemas, explica Sergio de los Santos, de la consultora Hispasec: “Las claves han podido ser generadas en Debian y después usadas en Windows, ya que los formatos de archivo son estándar. El espectro es virtualmente infinito”.

El gurú de seguridad Bruce Schneier lo ha llamado “el gran lío” y no es para menos ya que no se soluciona aplicando un parche si no que : “Hay que regenerar manualmente las claves, revocar las antiguas, certificarlas, comprobar dónde fueron a parar las inseguras, cambiar contraseñas. Y los usuarios no podemos saber si el administrador del sitio al que nos conectamos lo ha hecho o no”, explica Sergio de los Santos.

Pueden leer el texto completo en | Un grave fallo en Debian pone en peligro millones de maquinas en internet
Gracias a Nierox que esta dandole seguimiento al caso veo una entrevista a Jordi Mallach, desarrollador de Debian, sobre el bug de Debian que les comente anteriormente.

Copio y pego la entrevista a este gran personaje

“¿A quién afecta esto?

El impacto es enorme. La biblioteca libssl de Debian y sus distribuciones derivadas ha estado generando material criptográfico débil durante casi dos años. En Debian la mayoría de la gente ha estado afectada desde el lanzamiento de la última versión, etch, hace un año, pero los usuarios de Ubuntu han estado expuestos al error durante tres versiones.

Debian es bastante popular en ambientes universitarios y entre muchos administradores de sistemas, y Ubuntu es el líder en los usuarios domésticos, con lo que estamos hablando de millones de ordenadores
afectados. Ahora bien, es difícil de estimar cifras concretas porque nadie sabe, ni puede saber a ciencia cierta cuantas instalaciones de Debian o Ubuntu hay en el mundo; existe una opción en ambas
distribuciones, desactivada por defecto, que permite saber de la existencia de esa instalación y la versión de sus paquetes instalados, pero el porcentaje de usuarios que la han activado es ínfima.

Lo más grave es que no sólo los usuarios de Debian deben estar intranquilos. Todos los administradores de servidores con SSH o certificados SSL, sean o no basados en Debian, deberían hacer una comprobación exhaustiva de todos sus certificados SSL y claves SSH en busca de claves vulnerables, porque pueden tener autorizadas claves públicas débiles, que podrían permitir entradas a sus servidores.

Por ejemplo, por la manera que se usan las claves SSH de tipo DSA, no es exagerado decir que *todas* las claves DSA, tanto las generadas en máquinas vulnerables o en máquinas “seguras” deberían considerarse comprometidas y no usarse más. Algunos administradores están recomendando desactivar el soporte para claves DSA y usar sólo RSA a partir de ahora. Y eso no significa que las claves RSA sean seguras. No lo son, si se han generado en sistemas con una libbssl débil.

¿Qué significa para las empresas? ¿A qué peligros las expone?

Básicamente deberán estudiar el uso que hacen de la criptografía en sus sistemas, entender hasta dónde hay riesgos incluso si no usan Debian o Ubuntu e invertir el tiempo necesario en asegurarse de que no están autorizando ninguna entrada insegura en el sistema. De no hacerlo, es más que probable que si tienen servidores afectados accesibles desde Internet, estos acaben infectados por gusanos diseñados para aprovechar esta vulnerabilidad.

(más…)

[Video] Con Linux puedes volar…

Hace dias aparecio por la red un video donde, se veia unos pingüinos volando, al parecer decin que era real ya que estaba grabada por la BBC, sin embargo despues resulto que era un especie de campaña.

Bueno, pues resulta que ha alguien se le ocurrio la gran idea de adaptarlo a un comercial sobre linux, el resultado es estupendo.

No hablo mas aqui esta el video.

[youtube]http://es.youtube.com/watch?v=PLHjT5-XM9o[/youtube]

Simplemente impresionante, si hubiera sido cierto estariamos ante el descubrimiento del siglo, o del milenio jaja.
Via | Con Linux todo es posible

[Linux] Requerimiento de algunas distros de Linux

En el blog de Nierox ha posteado una tabla dodne vemos los requerimientos de linux, los cuales son obviamente mucho menor que los de Windows aunque linux incluye muchas cosas mas, y claro sin atarse a ninguna empresa.

Distro gnu/Linux CPU (procesador) RAM
(Mínimo)
RAM
(Recom.)
Espacio en disco (mínimo) Espacio en disco (Recom.)
openSUSE 10.3 Intel Pentium 1-4, Celeron, AMD Duron, Athlon, Athlon 64, Semprom u Opteron 256 MB 512 MB 500 MB 3 GB
openSUSE 10.1 Intel Pentium 1-4, Celeron, AMD Duron, Athlon, Semprom u Opteron 256 MB 512 MB 500 MB 3 GB
CentOS 5 Intel Pentium I/II/III/IV/Celeron/Xeon, AMD K6/II/III, AMD Duron, Athlon/XP/MP, (Pendiente Itanium, Athlon 64, PowerPC) 128 MB 512 MB 1.2 GB 2 GB
CentOS 3/4 Intel Pentium I/II/III/IV/Celeron/Xeon, AMD K6/II/III, AMD Duron, Athlon/XP/MP, Itanium, Athlon 64, PowerPC 128 MB 256 MB 800 MB 2 GB
Mandriva 2008 Cualquier procesador Intel o AMD, 1Ghz o superior. Soporte para procesadores dual-core. 256 MB 512 MB 3 GB 4 GB
Mandriva 2007 Pentium 1-4, Celeron, Athlon, Duron, Sempron. 256 MB 512 MB 500 MB 4 GB
Mandriva 2006 Intel Pentium 1-4, Celeron, AMD Duron, Athlon, Semprom, Opteron, K6, Via C3 128 MB 256 MB 500 MB 4 GB
Fedora 8 Intel Pentium 2-4, Celeron, AMD Duron, Athlon, Semprom u Opteron 128 MB*/194 MB** 256 MB 500 MB 3 GB
Fedora 7 Intel Pentium 2-4, Celeron, AMD Duron, Athlon, Semprom u Opteron 128 MB*/194 MB** 256 MB 500 MB 3 GB
Fedora Core 5 Intel Pentium 1-4, Celeron, AMD Duron, Athlon, Semprom u Opteron 64 MB*/194 MB** 256 MB 500 MB 3 GB
Debian 3.1 Intel Pentium 1-4, Celeron, AMD Duron, Athlon, Semprom u Opteron 32 MB*/194 MB** 256 MB 500 MB 3 GB
Debian 3.0 Intel Pentium 1-4, Celeron, AMD Duron, Athlon, Semprom u Opteron 16 MB*/64 MB** 128 MB 450 MB 4 GB
Xubuntu 7.10 Intel o AMD con velocidad de 500mhz 64 MB/192 MB*** 128 MB 1.5 GB 4 GB
Kubuntu 7.10 Intel o AMD con velocidad de 500mhz 384 MB 384 MB 4 GB 4 GB
Ubuntu 7.10 Intel o AMD con velocidad de 500mhz 256 MB 384 MB 4 GB 4 GB
Ubuntu 6.06 Intel o AMD con velocidad de 500mhz 256 MB 256 MB 2 GB 3 GB
Ubuntu 5.10 Intel o AMD con velocidad de 500mhz 192 MB 256 MB 2 GB 3 GB
Slackware 486 o superior 16 MB 32 MB 100 MB 3.5 GB
Damn Samll 3.0 486DX o superior 16 MB 128 MB
Damn Samll 1.0 486DX o superior 16 MB 64 MB
Slax 5.1 486, Pentium o AMD 36 MB fluxbox 96 MB
KDE 144 MB
Puppy 2 Pentium 166MMX o superior (Intel o AMD) 128 MB 128 MB
simplyMEPIS 6 Intel Pentium o AMD Athlon 128 MB 512 MB 2 GB 3 GB
Knoppix 5 Intel Pentium o AMD Athlon 32 MB*/96 MB** 128 MB

Agrego tambien los requisitos minimos para Debian 4.0 Etch.

Tipo de instalación RAM (mínimo) RAM (recomendado) Disco duro
Sin escritorio 64 Megabytes 256 Megabytes 1 Gigabyte
Con escritorio 64 Megabytes 512 Megabytes 5 Gigabytes

Visto en | Tabla de requerimientos de algunas distros GNU/Linux.
Agredado Requerimientos Debian 4 | Requisitos mínimos de sistema recomendados

[Linux] Intrepid Ibex: El nombre de Ubuntu 8.10

Pues como ya saben yo no soy ubuntero, mas bien soy debianita(asi se dice?), por que pues es cuestion de gustos y otras cosas mas, pero bueno dejemos la dicusion para otra ocasion.

Bueno, pero mientras sean noticias de linux siempre seran buenas, bueno en que estabamos?.ha si.

ubuntu

Mark Shuttleworth, el fundador de Canonical LTD. ha anunciado que el nombre del sucesor de buntu 8.04 LTS (Hardy Heron) sera Ubuntu 8.10 (Intrepid Ibex).

“atrae una considerable atención en la industria y en nuestros entusiastas usuarios finales. Nuestras pruebas iniciales con Hardy Heron son muy prometedoras y estamos planeando los detalles que ofreceremos en Intrepid Ibex”

indicó Shuttleworth.

Ubuntu 8.10 (Intrepid Ibex) sera la novena versión de esta distribucion,y casualmente coincidirá con el cuarto aniversario desde que Ubuntu hizo su primera aparicion.

Bueno y para los debianeros pronto les tendre noticias de Debian 5 (Sid).

Via | “Intrepid Ibex” será el nombre de Ubuntu 8.10

[Linux] Se hara el ¿Dia mundial anti-windows? …..

Para todos los usuarios del mundo principalmente usuarios windows.

Nosotros, los abajo firmantes nos unimos a la jornada mundial anti Windows, por considerar este un sistema deficiente, pesado , caro y altamente restrictivo, creemos en que el software es una herramienta de la humanidad y así debe permanecer. La ultima versión de windows es una ofensa a la humanidad.

la ignoracia y la falta de acceso a las tecnologias fueron nuestro enemigo… ahora lo conocemos por eso, nos comprometemos a publicar en nuestros blogs, servicio de mensajería instantatea o pintar en nuestros carros la frase día mundial contra el Windows, durante el 26 de enero de 2008, fecha en la que se reúne el Foro económico mundial.

para ese dia debe estar listo el cambiazo a distribuciones de software libre u otras alternativas como el Windows desatendido. de la misma manera y siguiendo los principios de la comunidad GNU ayudaemos a los que tengan suficientes conocimientos acerca de com hacer la migracion y como usar el nuevo software.

deja tu nombre y tu blog o alguna forma de contactarte, asi seremos mas y nos conoceremos:

¿Exageracion?, quizas pero igual y sirve de algo esta medida, ya que vimos que con el windows Vista, Microsoft Fracaso, creo que vamos ganado!!!.

Pueden dejar su firma aqui: http://www.petitiononline.com/anti2008/petition-sign.html?

Linux

Via | Día Mundial Anti-Windows!
OJO: Usa debian, cuesta un chingo aprender a usarlo, pero despues nunca aceptaras dejarlo.

[LPIC] Dispocision de los archivos en GNU/Linux -I

Continuando con la enseñanza de GNU/Linux, que por cierto mi Debian me esta dando varios dolores de cabeza, por que ahora no puedo acceder al explorador de archivos pero bueno, es cualquier cosa.

En GNU/Linux, sin importar el tipo de distribucion que se trate, siempre tendra una estructura practicamente igual de algunos directorios, estos directorios seran los siguientes.

Directorio / (slash)

Este es el directorio raiz, de donde parten los siguientes directorios, cuando se especifiquen rutas absolutas, estas deberan expesar de este directorio.

Directorio /bin
Este directorio de contiene los ejecutables, los cuales son fundamentales para el funcionamiento de Linux, la mayoria de los comandos usados en linux como, rm, cp, tar, etc,

Todos los archivos ejecutables o binarios que se encuentran en este directorio son accesibles a todos los usuarios, debemos tambien recordar que los archivos que no son fundamentales para el funcionamiento del sistema estan en el directorio /usr/bin en lugar de /bin.

(más…)

[LPIC] Cambiando contraseñas de usuarios en GNU/Linux

Siguiendo con mi enseñanza, de linux, hoy cheque como hacer esto de cambio de contraseñas de GNU/Linux.

Para poder cambiar la contraseña de un usuario necesitamos una de las siguientes dos cosas.

Ser root o ser el dueño de la cuenta la cual deseamos modificar el password.

La pregunta sencilla es, ¿Como se cambia?, la respuesta es simple, en nuestro linux abrimos una consola, o (si no usan entorno visual[kde,gnome,eligtmenth]) escribimos el comando siguiente.

//como usuario de la cuenta
$ passwd [nueva_contraseña]

//o de esta forma
$ passwd [enter]
Ingrese su nuevo password:
Repita su password:

ó

//Como root
# passwd [usuario] [enter]
Ingrese su nuevo password:
Repita su password:

Bueno con eso ya podran modificar sus contraseñas de los usuarios.

Nota: Tengo en mente un proyecto que la otra vez les platique, sin embargo como hire po partes vas a ser 3 proyectos, pero me voy a apurar para poder terminar uno a mas tardar en un mes(ups), que se que les va aser de gran ayuda a todos.

Saludos